Back to overview
Downtime
Console and radio player unavaible
Mar 2, 2025 at 8:07pm UTC
Resolved
Mar 2, 2025 at 9:36pm UTC
Service are now back online. Sorry for the inconvenience caused by this.
If you still have any issue, don't hesitate to contact our support.
Affected services
Updated
Mar 2, 2025 at 9:20pm UTC
Still waiting on a resolution, no new update.
Radios server are working, but the player and console are affected by this incident.
Affected services
Updated
Mar 2, 2025 at 8:28pm UTC
It's a power issue at the datacenter. We are waiting on a resolution.
Affected services
Created
Mar 2, 2025 at 8:07pm UTC
We have aware of this issue and investigating.
Affected services